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Resistance to HIV 

(Computer-based version of the exercise) 

 

In the early 1990s a number of studies revealed, that some people – although they had 

repeatedly contact with HIV – did not become carriers of HIV or, in the case of a confirmed 

HIV-infection, showed a delayed onset of the disease (AIDS) (a delay of several years was 

reported). First attempts to explain these phenomena were observed a few years later, when 

scientists identified important co-receptor molecules on the surface of the host cells, which 

are essential for HIV to infect the host cell. Scientists assumed that resistant persons may 

carry an aberrant version of the co-receptor molecule, which makes it impossible for the virus 

to enter the host cell. Such a co-receptor is the chemokine co-receptor CCR5, which is 

normally involved in the host’s immune answer (Dean & O’Brien, 1998).     

In order to test their hypothesis, the scientists sequenced the genes which code for the co-

receptor CCR5. They investigated more than 700 samples from HIV-infected patients and 

compared them with the CCR5-sequences from more than 700 healthy persons. The results of 

the DNA-sequencing revealed mutations in the CCR5-gene in HIV-infected persons with a 

delayed onset of AIDS as well as in some samples of healthy persons (but not in HIV-patients 

with typical onset of AIDS) (Samson et al., 1996).   

 

 

Exercises 

 

1. Search on the website of NCBI (www.ncbi.nlm.nih.gov) by yourself and find 

complete sequences of the CCR5-gene as well as the mutant CCR5-gene.  

a. In order to do so, first choose the database option ‘nucleotide’ in the SEARCH 

menu and search for the accession numbers AY463215.1 and U66285.1!   

b. Download the sequences in FASTA-format and save them at an appropriate 

place in your computer. (The option download is indicated on the upper right 

site of the website. By choosing FASTA as data-format, the sequence can be 

saved for the following steps) 
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2. Open the program GeneDoc and import the selected sequences. Align the sequences 

by searching for matching parts within the sequences (for aligning the sequences, see 

manual on p.5).  

a. Find out, were the difference is and 

b. define, what kind of mutation it is. 

 

3. Formulate hypotheses about the consequences such a mutation may have for the 

following translation of the sequence amino acids during protein biosynthesis.   

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 

 

4. Test your hypotheses by resetting the sequences into the original state (without gaps) 

and by letting the program translate the DNA-sequences into amino acid sequences 

(see manual on p.5). What are the differences between the resulting proteins? 

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 

 

Optional task (if time allows or a higher level of difficulty compared to task 1a is desired)  

5. Search the website of NCBI (www.ncbi.nlm.nih.gov) by yourself for 2 or more 

complete sequences (‚complete cds’) of the CCR5-gene as well as the mutant CCR5-

gene, by using adequate key words (for example ‘CCR5 chemokine receptor’). 

Complete the download of the sequences as described in task 1b and enlarge your 

alignment (see manual on p.4).   
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Additional information:  

The gene for the co-receptor CCR5 is located on the third human pair of chromosomes. There 

are two alleles for this locus. If the two alleles are identical, the person is homozygous. If the 

alleles are different, the person is heterozygous.  

If a person is homozygous for the “standard”-allele CCR5 (CCR5/CCR5), he or she is not 

resistant to HIV. If the person is heterozygous, which means he or she bears both a standard 

allele CCR5 and a mutant allele CCR5Δ32 (CCR5/CCR5Δ32), the onset of the disease will be 

delayed. In fact, only persons who are homozygous for the mutant allele (CCR5Δ32/ 

CCR5Δ32) are resistant to an infection with HIV. 

6. Explain why only persons who are homozygous for the mutant allele are resistant to 

an HIV-infection, while being heterozygous just means that the onset of the disease is 

delayed!  

________________________________________________________________________

________________________________________________________________________

________________________________________________________________________

________________________________________________________________________ 

________________________________________________________________________

________________________________________________________________________

________________________________________________________________________

________________________________________________________________________ 
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Research on sequences with GenBank® 

Short Manual 
 
In order to compare authentic sequences, we can use genetic databases in the internet. The 
sequence data of all genetic databases are publicly administrated and freely available on the 
web-sites of different organizations. GenBank® is provided by the NIH (National Institute of 
Health) in the USA and administrated by the NCBI (National Center for Biotechnology 
Information, www.ncbi.nlm.nih.gov). It is one of the databases, which collects, manages and 
utilizes DNA-sequences. Genetic databases are the result of scientific publications because 
most scientific journals call for the registration of sequences in central public databases when 
the research paper is published. In GenBank® approximately 106 billion nucleotides in more 
than 108 million sequences have been recorded (August 2009). 
The homepage of the NCBI provides easy access to research on sequence data. A dropdown 
menu at the top of the page allows for a selective search of specific sequence data – it is 
possible, for example, to search for specific DNA-sequences by choosing Search: 
„Nucleotide“. The search is text-based, therefore you can use the name of species or genes, 
authors, accession numbers or the like as key words, for example Search „Nucleotide“ for 
„CCR5 mutant chemokine receptor“.  
The search results in a list of matches, which are designed as hyperlinks and lead to the 
complete database entry. Below the description, you can find the accession number, which 
allows for exact identification of the sequence and should always be noted as reference 
because the names of genes are not subject to a universal nomenclature. The list changes 
continuously because the database is regularly updated. From the list you choose the best 
match for your research question. In the present exercise ‘Resistance to HIV’ you first narrow 
your search to sequences in the human genome and then select ‘Homo sapiens mutant CCR5 
chemokine receptor (CCR5) gene, complete cds’ (Accession number AY744141.1). The 
database entry comprises detailed information on the sequence (e.g. the number of 
nucleotides, completeness of the sequence, etc.), the biological species of the organism, the 
corresponding publication, further literature as well as the sequence of amino acids coded by 
the DNA-sequence. Some of these descriptions are created as hyperlinks and lead to further 
relevant databases (e.g. information on systematics etc.). At the end of each entry you can find 
the DNA-Sequence you looked for. 
This DNA-sequence of the database entry is displayed in the data format ‘GenBank’; further 
options for data formats can be found below the name of the gene: ‘FASTA’ or ‘Graphics’. 
The data format GenBank is not suited for transferring sequences between different analysis 
programs. The FASTA-format (.aa) is suited much better for this because it is compatible 
with many analysis programs. This holds true for nucleotides sequences as well as for amino 
acid sequences. In order to change formats, look for the option ‘Send’ on the top right on the 
page. By clicking this link, you can open a dropdown menu; it is recommended to select 
‘Complete Record’ and to select the option ‘File’ within ‘Choose Destination’. A submenu 
opens, where you can choose the data format. By selecting the data format FASTA the 
sequence can be saved for further editing in an analysis program.  
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Tutorial GeneDoc 

 
GeneDoc 
Multiple Sequence Alignment Editor & Shading Utility Version 2.6.002 
Copyright © 2000 by Karl Nicholas 
 
This tutorial describes first elementary steps of a sequence alignment with the computer 
program GeneDoc. It provides insights into the scientific work on sequence analyses but 
makes no claim to be complete.  
The computer program is offered as freeware by the producer (www.nrbsc.org/gfx/genedoc/).  
 
The construction of a data set 
Import of sequences:  
Select the menu ‘File’ > ‘Import’ in the menu. A separate window ‘Import Type’ opens, 
asking for definition of the data format of the sequence. Generally, the data format FASTA 
(Pearson) fits and the import of the sequences can be started by clicking on ‘Import’. [The 
data format FASTA (Pearson) (name.aa) is compatible with many computer programs]. In the 
FASTA-format, the data file can be uploaded and opened. After each opening of a sequence 
data file, the window ‘Import Type’ pops up again and further data files can be added. If the 
data set is complete, you can click on the option ‘Done’ in the window ‘Import Type’ and the 
window closes.   
The program presents a listing of the sequences. On the left side you can see the name of the 
sequence and after a colon the complete sequence is displayed in a horizontal line.  
If you want to open an existing alignment for further editing, you can also select the menu 
‘File’ > ‘Import’ and choose the adequate data format. Again, the FASTA (Pearson)-format is 
available, which is displayed as filename.aa, or in other formats, e.g. the Clustal-format, 
which can be recognized by the extension .aln.   
 
 
Editing of the sequences / of the alignment 
 
Renaming of sequences 
The sequences are often named in impractical ways and therefore the user has the possibility 
to rename the sequences. In order to do so, choose the menu ‘Project’ > ‘Edit Sequence List’. 
All sequences of the data set are listed in a new window. After double-clicking on the name of 
the sequence, another window opens with the actual name of the sequence. This name can be 
replaced by an alternative name and confirmed by ‘OK’ [the first 10 letters will be visible in 
the alignment (presetting)].  
 
 
Degree of consensus between different sequences  
The nucleotides are shaded in different colors of grey, which indicate the degree of consensus 
between the different sequences. It is possible to vary the number of shades of grey by special 
buttons in the menu. The following options are available: 0, 2, 3 or 4 shades of grey. Level 4 
was used in the example below. After each movement of the sequences the shading can be 
refreshed by clicking the respective button.  
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Movement of the sequences 
In the menu, there are two buttons for moving single nucleotides (Grab and Slide 1) and 
complete sequence sections (Grab and Drag 2).   
 
 
Search for matches    
In order to compare the sequences, it is necessary to look for matches. This can be done 
manually or with the help of the search function of the program. Choose ‘Edit’ > ‘Find’ in the 
menu, or click on the shortcut: . The window ‘Find Dialog’ opens, where you can enter a 
short sequence of nucleotides from one of the complete sequences in the field ‘Find String’ 
(3). The option ‘Find all and shade’ (4) should be selected. You can change the shading 
color by clicking on ‘Text Color’. Finally click on the 
button ‘Find’ and the program will search for matching 
nucleotide sequences throughout all sequences. Also, the 
matches will be marked in the chosen color.   
 

 
 
 

This procedure significantly simplifies the alignment of the 
sequences. In order to confirm the matches, the edited 
alignment should be tested for the degree of consensus again 
and again, but colored marks will then get lost. If there will 
be no matches identified, you can search for new sequences 
or allow a number of mismatches. For this purpose you can 
enter a number of tolerated ‘Mismatches’ or 
‘Insertions/Deletions’ in the window ‘Find Dialog’ (5).  
 
 
Saving the alignment 
An alignment can be saved for further editing in GeneDoc or for further analyses with other 
programs. In this case you can save the data in FASTA-format or – as an alternative – in the 
Clustal-format by choosing the menu ‘File’ > ‘Export’. An alternative way to save the data is 
to choose ‘Project’ > ‘Edit Sequence List’ > ‘Export’.  
 
 
Translation of DNA-sequences into amino acid sequences 
In an alignment, you can compare nucleotides from DNA-sequences as well as the resulting 
amino acid sequences. The translation of sequences of nucleotides into sequences of amino 
acids can be done by the program. Before doing so, however, all gaps inserted for the 
alignment have to be removed (the gaps only serve the purpose of demonstrating insertions 
and deletions). 
In order to run the translation process, choose the menu ‘Project’ > ‘Trans DNA to Protein’. 
The window ‘DNA/RNA Translation’ will open, where you can find a list of the amino acid 
coding (9). You can determine the ‘Translation Options’, e.g. by defining the reading 
frame. You can e.g. determine a frame shift of 1 or 2 nucleotides, in particular when the 
sequence begins with an incomplete nucleotide triplet (10).  
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The amino acid sequence occurs in a new window, 
so that you just have to minimize the window in 
order to see the DNA-sequences again.    
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Proposal for solution 

2a. 
Lack of 32 bases starting at base 554 
 
Detail from GeneDoc: 

 
 
2b. Deletion 

 
3. 
a. Frameshift and thus a different sequence of amino acids (primary structure) and as a 
further consequence different secondary and tertiary structure of the protein.  
b. Frameshift and thus a different sequence of amino acids and early generation of a stop-
codon, which determines a shorter protein.  
c. no frameshift, number of deleted bases is a multiple of 3. 
 
4.  
Frameshift and thus a different sequence of amino acids and early generation of a stop-codon 
which determines a shorter protein. This leads to a lack of three transmembrane segments on 
the CCR5 receptor, which are essential for binding of HIV (see: “illustration of the 
modification”).  
 
standard allele (partial sequence from amino acid 170 to 216): … Gln, Lys, Glu, Gly, Leu, His, Tyr, Thr, Cys, 
Ser, Ser, His, Phe, Pro, Tyr, Ser, Gln, Tyr, Gln, Phe, Trp, Lys, Asn, Phe, Gln, Thr, Leu, Lys, Ile, Val, Ile, Leu, 
Gly, Leu, Val, Leu, Pro, Leu, Leu, Val, Met, Val, Ile, Cys, Tyr, Ser, Gly,… 
 
mutant allele (partial sequence from amino acid 170 to 216): … Gln, Lys, Glu, Gly, Leu, His, Tyr, Thr, Cys, Ser, 
Ser, His, Phe, Pro, Tyr, Ile, Lys, Asp, Ser, His, Leu, Gly, Ala, Gly, Pro, Ala, Ala, Ala, Cys, His, Gly, His, Leu, 
Leu, Leu, Gly, Asn, Pro, Lys, Asn, Ser, Ala, Ser, Val, Ser, Lys, STOP 
 
Detail from GeneDoc: 

 
 
 
6. 
In persons who are homozygous for the mutant allele, the co-receptor CCR5 is exclusively 
produced in the modified, nonfunctional version, thus HIV is not able to infect the host cell. If 
the person is heterozygous for the mutant allele, the functional co-receptor is expressed to a 
minor degree. HIV is able to infect the host-cells, however to a lesser degree, so that the onset 
of the disease is delayed.  
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Illustration of the modification:  
 

 
Intact co-receptor CCR5 and binding of HIV on the cell-surface 
 

 
 
 
Mutant co-receptor CCR5Δ32  
 

 

 
 
Because of the early interruption of the protein biosynthesis the mutant protein lacks the last 
three transmembrane-segments. Thereby the binding of HIV to the host-cell is impossible and 
the fusion of the membranes is not initiated.  
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