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Information material  

Resistance to HIV – Research and analysis of molecular data 
(incl. manuals for the research on sequences with GenBank® and for the analysis of 

sequences with GeneDoc) 

 
The computer-based version of the exercise “Resistance to HIV” consists of doing internet-

based research on DNA-sequences and comparing sequences with the computer program 

GeneDoc. Information on how to do the research and how to compare molecular sequences, 

can be found below.   

  

Research on sequences with GenBank® 

In order to compare authentic sequences, we can use genetic databases in the internet. The 

sequence data of all genetic databases are publicly administrated and freely available on the 

web-sites of different organizations. GenBank® is provided by the NIH (National Institute of 

Health) in the USA and administrated by the NCBI (National Center for Biotechnology 

Information, www.ncbi.nlm.nih.gov). It is one of the databases, which collects, manages and 

utilizes DNA-sequences. Genetic databases are the result of scientific publications because 

most scientific journals call for the registration of sequences in central public databases when 

the research paper is published. In GenBank® approximately 106 billion nucleotides in more 

than 108 million sequences have been recorded (August 2009). 

The homepage of the NCBI provides easy access to research on sequence data. A dropdown 

menu at the top of the page allows for a selective search of specific sequence data – it is 

possible, for example, to search for specific DNA-sequences by choosing Search: 

„Nucleotide“. The search is text-based, therefore you can use the name of species or genes, 

authors, accession numbers or the like as key words, for example Search „Nucleotide“ for 

„CCR5 mutant chemokine receptor“.  

The search results in a list of matches, which are designed as hyperlinks and lead to the 

complete database entry. Below the description, you can find the accession number, which 

allows for exact identification of the sequence and should always be noted as reference 

because the names of genes are not subject to a universal nomenclature. The list changes 

continuously because the database is regularly updated. From the list you choose the best 

match for your research question. In the present exercise ‘Resistance to HIV’ you first narrow 

your search to sequences in the human genome and then select ‘Homo sapiens mutant CCR5 
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chemokine receptor (CCR5) gene, complete cds’ (Accession number AY744141.1). The 

database entry comprises detailed information on the sequence (e.g. the number of 

nucleotides, completeness of the sequence, etc.), the biological species of the organism, the 

corresponding publication, further literature as well as the sequence of amino acids coded by 

the DNA-sequence. Some of these descriptions are created as hyperlinks and lead to further 

relevant databases (e.g. information on systematics etc.). At the end of each entry you can find 

the DNA-Sequence you looked for. 

This DNA-sequence of the database entry is displayed in the data format ‘GenBank’; further 

options for data formats can be found below the name of the gene: ‘FASTA’ or ‘Graphics’. 

The data format GenBank is not suited for transferring sequences between different analysis 

programs. The FASTA-format (.aa) is suited much better for this because it is compatible 

with many analysis programs. This holds true for nucleotides sequences as well as for amino 

acid sequences. In order to change formats, look for the option ‘Send’ on the top right on the 

page. By clicking this link, you can open a dropdown menu; it is recommended to select 

‘Complete Record’ and to select the option ‘File’ within ‘Choose Destination’. A submenu 

opens, where you can choose the data format. By selecting the data format FASTA the 

sequence can be saved for further editing in an analysis program.  

 

Alignment of sequences 

The purpose of the alignment is to compare two or more sequences of nucleotides or amino 

acids, detect patterns and find differences between the sequences which might have come into 

being in the course of evolution due to substitutions, deletions or insertions.  

An alignment has a vertical dimension and a horizontal dimension. The vertical dimension 

results from the fact that an alignment is a matrix, in which the taxa under investigation are 

listed one below the other. The sequences themselves are listed from left t right in the 

horizontal dimension. The sequences are aligned to each other, so that the vertical order is 

maintained, while each element (nucleotide) is assigned to a nucleotide or a gap of the other 

sequences. A special difficulty in constructing a good alignment are the so-called gaps, which 

have to be integrated in order to provide for the fact, that nucleotide sequences do not only 

change by interchange of nucleotides (substitutions) but also by a loss of nucleotides 

(deletion) or the incorporation of additional nucleotides (insertion).  

Generally, the alignment of protein-encoding nucleotide sequences is easier than the 

alignment of other sequence sections because they can be verified by translating them into 
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amino acid sequences. Thus, in such protein-encoding nucleotide sequences deletions or 

insertions should always occur as a multiple of 3; if this is not the case, the reading frame of 

the encoded protein is destroyed. Most substitutions are expected to be located in the 3rd 

position of the codon because these in this position often won’t change the meaning of the 

codon.  

In small exemplary exercises (like for example ‘Resistance to HIV’) the comparison of two 

sequences is practicable by hand, but alignments of many taxa with various mutations have to 

be analyzed with the help of computer programs. But even a computer based alignment 

should always be verified manually before further analyses are carried out.    

Aligned sequences can be presented quite nicely with the computer program GeneDoc, 

although the alignment will not be generated automatically by the program but has to be 

edited manually (description of the program and tutorial can be found in ‘GeneDoc’, p.4). 

Sequences can also be automatic aligned and subsequently analysed with the program Mega4, 

but we will not go into further detail for that.   

In most cases, the alignment of sequences serves as the basis for analysing relationships 

between organisms, e.g. calculating molecular phylogenetic trees. Therefore it is very 

important to work accurately. The alignment is the first step for constructing a molecular 

phylogeny!   

http://www.evolution-of-life.com/�


4 
   

Evolution in high motion – Resistance to HIV – Research and analysis of molecular data (Information) 
 

www.evolution-of-life.com 
Janina Jördens  (corresponding author)  

Tutorial GeneDoc 
GeneDoc 

Multiple Sequence Alignment Editor & Shading Utility Version 2.6.002 

Copyright © 2000 by Karl Nicholas 

 

This tutorial describes first elementary steps of a sequence alignment with the computer 

program GeneDoc. It provides insights into the scientific work on sequence analyses but 

makes no claim to be complete.  

The computer program is offered as freeware by the producer (www.nrbsc.org/gfx/genedoc/).  

 

The construction of a data set 
Import of sequences:  

Select the menu ‘File’ > ‘Import’ in the menu. A separate window ‘Import Type’ opens, 

asking for definition of the data format of the sequence. Generally, the data format FASTA 

(Pearson) fits and the import of the sequences can be started by clicking on ‘Import’. [The 

data format FASTA (Pearson) (name.aa) is compatible with many computer programs]. In the 

FASTA-format, the data file can be uploaded and opened. After each opening of a sequence 

data file, the window ‘Import Type’ pops up again and further data files can be added. If the 

data set is complete, you can click on the option ‘Done’ in the window ‘Import Type’ and the 

window closes.   

The program presents a listing of the sequences. On the left side you can see the name of the 

sequence and after a colon the complete sequence is displayed in a horizontal line.  

If you want to open an existing alignment for further editing, you can also select the menu 

‘File’ > ‘Import’ and choose the adequate data format. Again, the FASTA (Pearson)-format is 

available, which is displayed as filename.aa, or in other formats, e.g. the Clustal-format, 

which can be recognized by the extension .aln.   

 

Editing of the sequences / of the alignment 

Renaming of sequences 

The sequences are often named in impractical ways and therefore the user has the possibility 

to rename the sequences. In order to do so, choose the menu ‘Project’ > ‘Edit Sequence List’. 

All sequences of the data set are listed in a new window. After double-clicking on the name of 

the sequence, another window opens with the actual name of the sequence. This name can be 
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replaced by an alternative name and confirmed by ‘OK’ [the first 10 letters will be visible in 

the alignment (presetting)].  
 

Degree of consensus between different sequences  

The nucleotides are shaded in different colors of grey, which indicate the degree of consensus 

between the different sequences. It is possible to vary the number of shades of grey by special 

buttons in the menu. The following options are available: 0, 2, 3 or 4 shades 

of grey. Level 4 was used in the example below. After each movement of the sequences the 

shading can be refreshed by clicking the respective button.  

 

 

 

Movement of the sequences 

In the menu, there are two buttons for moving single nucleotides (Grab and Slide 1) and 

complete sequence sections (Grab and Drag 2).   

 

 

Search for matches    

In order to compare the sequences, it is necessary to look for matches. This can be done 

manually or with the help of the search function of the program. Choose ‘Edit’ > ‘Find’ in the 

menu, or click on the shortcut: . The window ‘Find 

Dialog’ opens, where you can enter a short sequence of 

nucleotides from one of the complete sequences in the field 

‘Find String’ (3). The option ‘Find all and shade’ (4) 

should be selected. You can change the shading color by 

clicking on ‘Text Color’. Finally click on the button ‘Find’ 

and the program will search for matching nucleotide 

sequences throughout all sequences. Also, the matches will 

be marked in the chosen color.   
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This procedure significantly simplifies the alignment of the sequences. In order to confirm the 

matches, the edited alignment should be tested for the degree of consensus again and again, 

but colored marks will then get lost. If there will be no matches identified, you can search for 

new sequences or allow a number of mismatches. For this purpose you can enter a number of 

tolerated ‘Mismatches’ or ‘Insertions/Deletions’ in the window ‘Find Dialog’ (5).  
 

Changing the order of the list of sequences and deleting sequences     

It is helpful to change the order of the sequences in order to identify matching sequences or 

matching parts of sequences. In order to do so, you choose ‘Project’ > ‘Edit Sequence List’ in 

the menu; you now have the opportunity to mark a sequence by clicking on it and to change 

its position with the buttons ‘Move Up’, ‘Move Down’, ‘Move to Top’ or ‘Move to Bottom’ 

(6). It is also possible to sort the sequences by their names (7).   

In order to delete a sequence from the alignment, choose ‘Project’ > ‘Edit Sequence List’ and 

click on the option ‘Delete’ (8). A shortcut for this step is the button ‘S’:  

 

 

 

 

 

 

 

 

 

 

 

Saving the alignment 

An alignment can be saved for further editing in GeneDoc or for further analyses with other 

programs. In this case you can save the data in FASTA-format or – as an alternative – in the 

Clustal-format by choosing the menu ‘File’ > ‘Export’. An alternative way to save the data is 

to choose ‘Project’ > ‘Edit Sequence List’ > ‘Export’.  
 

Font size and printing of the alignment 

In order to achieve a better overview of your alignment, you can change the font size by 

choosing the menu ‘Project > ‘Edit Sequence List’ and ‘Configure’. In the file card ‘Project’ 
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you can change the ‘Font Settings’ (12pt are the presetting). The font size can be reduced, 

which is recommended, if you want to print out the alignment. A shortcut for the change of 

font settings is the button C: 

  

 

When the alignment is successfully finished, you can print the result by choosing the menu 

‘File’ > ‘Print’. It is recommended to print the document in landscape format.           

 

Translation of DNA-sequences into amino acid sequences 

In an alignment, you can compare nucleotides from DNA-sequences as well as the resulting 

amino acid sequences. The translation of sequences of nucleotides into sequences of amino 

acids can be done by the program. Before doing so, however, all gaps inserted for the 

alignment have to be removed (the gaps only serve the purpose of demonstrating insertions 

and deletions). 

In order to run the translation process, choose the 

menu ‘Project’ > ‘Trans DNA to Protein’. The 

window ‘DNA/RNA Translation’ will open, where 

you can find a list of the amino acid coding (9). 

You can determine the ‘Translation Options’, e.g. by 

defining the reading frame. You can e.g. determine a 

frame shift of 1 or 2 nucleotides, in particular when 

the sequence begins with an incomplete nucleotide 

triplet (10). It might also be necessary to test 

different versions. Students should be encouraged to 

point out the effects of frame shifts that may be 

caused by mutations (insertions or deletions).  

The amino acid sequence occurs in a new window, so that you just have to minimize the 

window in order to see the DNA-sequences again.    

 

Literatur und links:  
GenBank® (National Center for Biotechnology Information: www.ncbi.nlm.nih.gov). (Last access 
 July 2010) 
GeneDoc - Multiple Sequence Alignment Editor & Shading Utility Version 2.6.002, © 2000 by Karl 

Nicholas (www.nrbsc.org/gfx/genedoc/index.html) (Last access July 2010) 
Knoop, V. and K. Müller (2009). Gene und Stammbäume. Heidelberg, Spektrum Akademischer 

Verlag 
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